Jump to content

Bally/Stern Replacement MPU 'LISY35', Tester gesucht


bontango
 Share

Recommended Posts

  • Replies 187
  • Created
  • Last Reply

Top Posters In This Topic

Test im Nitro Ground Shaker.

Hi zusammen.

Da ich in der Exceltabelle gesehen habe, dass schon jemand die XENON und auch jemand den EBD testet, hab ich mir mal den Nitro Ground Shaker vorgenommen.

Zuerst das PIC gebrannt. Wildes Geflimmere der LEDs, danach grün. Um es vorwegzumehmen: LisyControl zeigt die neue Versionsnummer an. Hat also wohl geklappt.

Dann das Spiel:

Alles funktioniert wie gewohnt. Alle Lämpchen werden zutreffend angesteuert, alle Kontakte, alle Spulen reagieren wie gewohnt. Original-Sound von der original-Soundkarte kommt.

Ein einziger Unterschied zum Original ist mir aufgefallen: Beim Bonus-Raufzählen, aber vor allem beim Bonus-Runterzählen stockt er manchmal. Das Geräusch ist so ähnlich wie ein Maschinengewehr, und gegen Anfang des Runterzählens stockt es kurz. rata-rata-huch?-rata-rata-rata,rata-rata-rata,usw. bis zum Ende.

Bally-Kassentür-Routine (roter Knopf):

Funktionert wie gewohnt. Sowohl die Selbsttests als auch die Einstellungen (Freispiele, Highsore zurücksetzen) Nicht getestet hab ich die Buchführungsfunktionen (benutz ich nicht) Auch der Reboot nach der letzten Nummer funktioniert

Modifikation:

Getestet habeich die Freispielfunktion. Nach längerem Druck auf den Kreditbutton zählt er mir 4 Credit hoch. Scheint zu funktionieren 🙂 Ich würde mir aber eher so eine Funktion wünschen, dass die Credits nie unter 1 fallen (wie auf den Okaegi-ROMs)

LisyControl:

Langes Drücken des roten Knopfes bringt nicht LisyControl hoch. Er bleibt dabei, den Lampentest machen zu wollen. Per Dip-Eistellung (S1: 6 und 8 ein) gehts. Bei vier Versuchen folgende Bilanz:

  • 1x kein erkennbar konsequent beendeter Bootvorgang (keine Ahnung, wo er gelandet ist. LED-Ampel gelb)
  • 1x vier Anzeigen 000000.
  • 2x IP-Adresse in den Displays (beides Mal dieselbe) und Flipper unter der Adresse erreichbar.

Nun zu den Funktionen von LisyControl:

  • Switches.
    Funktioniert. Wenn ich einen Seitch betätige, wird er angezeigt. Beschreibender Test für Nitro Ground Shaker liegt wohl noch nicht vor (kann ich machen. Ist das so gedacht, dass die Tester diese Dateien zuliefern? Kann ich gerne machen)
  • Lamps.
    Funktioniert. Beschreibungsdatei der Lämpchen kann ich, analog zu Switches, anfertigen, wenn gewünscht.
  • Momentary Solenoids.
    Nix. Nur leere Buttons. Noch ncht implementiert?
  • Dauerhafte Solenoids.
    Vier Buttons, auf zweien höre ich das Flipperfingerfreigaberelais und die Münzfreigabe. Ich glaube fast, der Nitro GroundShaker hat auch nicht mehr Dauerspulen?
  • Displays.
    Lustig, in den Feldern steht erstmal die IP-Adresse 🙂 Mal was anderes eingetippt, wird übernommen.
  • DIP-Switches
    Zeigt für alle "aus". Meine spezifischen Einstellungen werden im Spiel aber benutzt! Aber nicht angezeigt. Noch nciht implementiert? Auch hier würde ich Beschreibungen liefern...
  • Sound
    Hier hab ich das Testergebins leider nicht aufgeschrieben und prompt auch vergessen. Ich werde es in Kürze nochmal testen. Sorry for that.
  • Software
    Zeigt die Nummern der PICs, bei dem selbstgeflashten die Nummer nach dem Flash (scheint also zu funktionieren)
  • update new configuration files:
    Hier sind nur Menüpunkte für andere Lisys, noch nicht für die -35

Fazit:

Hat großen Spaß gemacht zu löten, zu flashen, zu brennen, zu testen, zu spielen. Werde gerne weiter mitarbeiten, z.B. Konfigurationsfiles anfertigen, weiter testen. Gerne auch in der XENON und im EBD.

Danke und Gruß

Martin

Link to comment
Share on other sites

Und wieder ein Flipper der 'fast' grün markiert werden kann. Danke fürs ausführliche Testen.

Configfiles wären super, die würde ich dann jeweils ins Image aufnehmen.

Damit es einfacher wird mache ich dann für die nächste Version weitert an LISY_control und dem upload.

Wird 5.005 werden, 5.004 habe ich gerade hochgeladen, Bericht kommt gleich ...

Link to comment
Share on other sites

LISY 5.004 steht zum Update bereit, changes zu 5.003:

- WLAN Hostmode, mit eigenem Hotspot funktioniert jetzt ( WLAN client mode scheint aber etwas unzuverlässig)

- LISYcontrol kann jetzt auch während eines laufenden Spiels durch LANGES drücken des roten Testknopfes in der Kassentür gestartet werden

- die Lampen über die secondary Lampdriverboards 'sollten' jetzt auch funktionieren

- das Statusdisplay zeigt nacheinander die SW Versionen der PICs während des LISY boots

 

Noch offene bzw. bekannte Bugs habe ich auf lisy80.com unter die History geschrieben, falls euch noch was einfällt ...

 

Grüsse

Ralf

 

Link to comment
Share on other sites

Hi.

Ich habe mir nochmal das Stocken beim Bonusrunterzählen angeschaut und -gehört. Scoring und Leuchten der Lämpchen ist regelmäßig, nur beim Sound stockt es. 

Könnte es sein, dass die Emulation ein ganz klein bisschen schneller ist als das Original und er daher mit dem Sound nicht hinterherkommt? 

Auch wenn es mit dem Thema des Flippers gar nix zu tun hat, so erinnert doch der Sound an der Stelle nicht nur Todd N. Tuckey an ein Maschinengewehr. 

Kann man die Emulation ein klein wenig verlangsamen irgendwie? Ich würde gerne mal probieren, ob das einen Unterschied macht...

Gruß

Martin

Link to comment
Share on other sites

Also,

ich hab dann mal gleich mit +1000 angefangen.

Man merkt dern Untersched, die Bonuszählung wird tatsächlich langsamer (sonst hab ich es nirgens gemerkt). Leider bleibt der Stotterer im Sound genauso wie vorher.

Und dann habich mir noch den Spaß gemacht, und hab ihn mal 1000 schneller gestellt: Auch das merkt man nur am schnelleren Runterrattern der Bonusleiter. Interessanterweise bleibt der Effekt also das Stottern, gleich.

Also, ich meine, da kann man mit leben. Wenn man das original nicht kennen würde, müsste man denken, das gehört so. Ich würde sogar behaupten, eigentlich klingt es so viel besser.

Aber ein Unterschied zum Original ist es schon, das hinterläßt den Tester unbefriedigt.

Ich habe übrigens eben noch einen Unterschied zum original festgestellt: Beim Booten spielt das original ein Geräusch ab ("Vroum!") und löst beide Kickout-Holes aus. Das macht Lisy nicht.Ist mir eben erst aufgefallen, als der Ball man beim Booten im Kickouthole lag. Wo der dann auch liegen blieb (Einen Ballsearch gab es ja damals noch nicht...)

Gruß

Martin

P.S.: Hast Du eine Idee, woran das liegen könnte ...?

Link to comment
Share on other sites

vor 26 Minuten schrieb Thunfisch:

Aber ein Unterschied zum Original ist es schon, das hinterläßt den Tester unbefriedigt.

Kann ich mir derzeit nicht erklären woher der Effekt kommt. Dier DIP Switch Einstellung ist aber 1:1 zu deiner Originalplatine?

 

vor 27 Minuten schrieb Thunfisch:

Ich habe übrigens eben noch einen Unterschied zum original festgestellt: Beim Booten spielt das original ein Geräusch ab ("Vroum!") und löst beide Kickout-Holes aus. Das macht Lisy nicht.Ist mir eben erst aufgefallen, als der Ball man beim Booten im Kickouthole lag. Wo der dann auch liegen blieb (Einen Ballsearch gab es ja damals noch nicht...)

Das könnte an LISY liegen, wann im Bootvorgang macht er das im Original denn? Nach dem siebten 'blink' oder vorher?

Link to comment
Share on other sites

vor 14 Minuten schrieb bontango:

die DIP Switch Einstellung ist aber 1:1 zu deiner Originalplatine?

[...] wann im Bootvorgang macht er das im Original denn?

Erste Frage: Ja. Nein. Also, am Anfang schon. Nur die Kreditanzeige hab ich dann wieder eingeschaltet, um das Freispielfeature zu testen.

Zweite Frage: Ja. Nein. Im Prinzip. Also, zunächst mal, so ganz original ist mein Original auch nicht mehr. Ich verwende die ROMs von okaegi, wegen des Freispielfeatures (Kredite sinken nie unter 1) An welcher Stelle Vroum, klack, klack kommt, muss ich mal anschauen (dazu muss ich natürlich erstmal wieder die Originalplatine reinmachen) Ich habe eben nochmal genau hingeschaut und -gehört bei Bootvorgang der Lisy, das untere Kickouthole löst aus beim Bootvorgang. Der Ball lag halt im oberen 🙂

Gruß

Martin

Link to comment
Share on other sites

Hi,

ich habe Lisy nochmal gebootet mit zwei Bällen auf dem Spielfeld, in jedem Loch einen. Ganz kurz, bevor die Lisy-spezifischen Anzeigen verschwinden, und je zwei Nullen angezeigt werden, und die Münzfreigabespule ertönt, also ganz kurz vorher wird die eine Kugel im unteren Loch ausgeworfen. Die im oberen nicht. Nehme ich jetzt im Attract Mode die Kugel raus und lege sie wieder rein, wird sie ausgeworfen.

Original zum Vergleich poste ich, wenn ich die MPUs umgebaut habe 🙂

Gruß

Martin

Edited by Thunfisch
Link to comment
Share on other sites

Das machen alle alten Ballys nach dem booten. Wenn dann irgendwo auf dem Spielfeld ne Kugel im Loch liegt wird diese ausgeworfen. Das sollte aber eine Routine von Bally sein. Kann aber gut sein das das eine Sache der Emulation ist (darauf setzt Lisy ja auf). Am PC muss die Kugel nicht ausgeworfen werden. Die kommt immer unten aus der "Truhe" nach dem drücken des Startknopfes. Im wahren Leben ist das leider (etwas) anders, da muss die Kugel erst mal runter...

 

Link to comment
Share on other sites

Im log sehe ich dass er 'versucht' nach dem boot beide saucer zu leeren.

Habe auch schon eine Vermutung: Zum selben Zeitpunkt schreibt er im nvram vom PIC

rum und kommt dann wohl mit den solenoids in Verzug was zu einem extrem kurzen pulse für

die solenoids führt der nicht ausreicht um die Spule anziehen zu lassen.

Dazu muss aber das Solenoid PIC ein update bekommen.

Da ja die secondary AUX boards leider immer noch nicht 100% funktionieren, mache ich dass

dann zusammen mit nem AUX Board update in einem Aufwasch

Link to comment
Share on other sites

Test in der XENON

(Lisy-Version 5.004. PICS 1: 4.04 2: 4.03 3:4.01)

Boot:

  • richtig: Wirft beim Booten etwaig in Löchern gefangene Kugeln aus (beide, nacheinander)
  • nicht richtig: Wirft auch eine Kugel aus der Balltruhe in die Shooter Lane (nur beim Booten nach dem Einschalten, nicht beim Booten nach LisyControl)
  • Anzeige: Versonen der PICs werden im Credit/Ball-Display angezeigt.

Attract Mode:

  • Viele Lämpchen leuchten richtig, die in der Backbox (z.B. Eterity Light) nicht. Einige sind von Anfang an an, einige aus, und das bleibt auch so. (Wie erwartet, die Backbox hat das Aux. lamp board)

Gameplay:

  • Funktioniert. Lämpchen: wie attract Mode.

Sound:

  • Nicht richitg. Soundkarte spielt während des Spiels gelegentlich erratisch irgendwelche Sounds ab.

LisyControl:

  • Jetzt kommt LizyControl auch nach langem Druck auf rot.
  • Beim ersten mal nur Nullen, beim 2. Mal IP-Adresse (kann auch an meinem WLAN liegen, das zickt beim Anmelden manchmal rum. Machst Du retries, wenns nicht gleich klappt?)
  • switches: Im prinzip richtig, aber zusätzlich blinken immer wieder erratisch Switches auf (die in echt aber unbewegt sind)
  • lamps: anders als beim NitroGroundShaker tut sich hier gar nichts
  • momentary solenoids: Ja, geht, aber die Reihenfolge der (unbeschrifteten) Buttons stimmt nicht mit dem Manual überein.
  • constant solenoids:
    1 Flipperfingerfreigabe,
    2 oberes Auswurfloch (kein momentary im engeren Sinne 🙂 - kann aber sein, dass das so verschaltet ist - guck ich bei Gelegenheit nach),
    3 nichts,
    4 Coin accept
  • displays: Funktion ist schwer zu bedienen, weil die Felder initial voller Blanks sind., die man erstmal löschen muss, bevor man was eintragen kann. Muss man erstmal drauf kommen! Fehler: Auch in den 7-stelligen Displays kann man nur 6 Stellen eingeben
  • dip switches werden fälschlicherweise alle auf 0 angezeigt.
  • sound: nix

Hoffe, weitergeholfen zu haben. Spaß gemacht hats mir.

Danke und Gruß

Martin

Link to comment
Share on other sites

vor 16 Minuten schrieb Thunfisch:

Hoffe, weitergeholfen zu haben.

Auf alle Fälle! 👍

Ich glaube auch den AUX Board bug zumindest für das kleine Board 2518-43 ( im Kiss und Centaur) gefunden zu haben, post gleich mal ein update 5.005

( da 'könnte' auch das Ballauswurfproblem mit dem Nitro Groundshaker behoben sein ..)

Link to comment
Share on other sites

Es geht weiter, kleine Schritte, aber ..

Hier die Version 5.005, die jetzt mit dem secondary soundboard 2518-43 ( z.B. Kiss & Centaur) laufen sollte.

Ich habe auch Hoffnung dass die kleineren Probleme beim Main Lampdriverboad sowie die 2518-53er Board (Pac Man) behoben sind

Webseite mache ich morgem Ihr könnt aber hier  http://www.flipperkeller.de/lisy/LISY_Version_5_005.zip schon downloaden.

 

Wer sich nicht jedesmal 1,5 GB ziehen und die SD Karte beschreiben will UND LISY am Internet hängen hat, kann auch mal die updatefunktion in LISY_Control ausprobieren.

Dafür im entsprechenden Menüpunkt in LISY_control diese URL eintragen: http://www.flipperkeller.de/lisy/lisy_update.tgz

So alles gut geht, meldet sich nach einem reboot dann 5.005 ( zu sehen in 'Software' in Lisycontrol oder beim booten im Flipper)

 

Grüsse

Ralf

Link to comment
Share on other sites

Gerade die 5.005 über die Updatefunktion ausprobiert.

Hat einwandfrei funktioniert. Nach dem Boot erscheint die neue Versionsnummer im Player 4 Display.

Das AUX-Driver Problem beim Centaur ist damit gefixt. Alle Lampen werden nun im Attract-Mode, Lampentest und Spiel fehlerfrei angesteuert.

Als einziges Lampenproblem beim Centaur fällt mir nur noch auf, das die 10, 30 und 40 Thousand Bonus Lampen vor der Chamber zwar im Attract-Mode und Spiel einwandfrei leuchten aber im Lamp-Test nicht.

Gruß

Holger

 

Link to comment
Share on other sites

Danke Charly,

ich werde das mal mit einem anderen Lamp Driver Board testen. Vielleicht mal wieder ein Stecker- / Stiftleisten Problem.  Hab sowas ähnliches auch bei den Displays. Da fehlen im Spiel bei zwei Displays mittendrin Ziffern aber im Displaytest läuft bis auf das bekannte Fehlen der 7. Stelle alles sauber. Ich vermute bei den betroffenen Displays, dass es die Steckverbindungen sind. Warum da jeweils ein unterschiedliches Verhalten im Spiel- und Testmodus und dann nur mit dem Lisy Board auftritt, ist schon irgendwie seltsam.

Gruß

Holger

Edited by holli8123
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

Privacy Policy and Community Guidelines