Jump to content

Recommended Posts

"For displays with 2x 16 alphanumeric characters pin2 of this jumper must be shorted to +5V, for all other kinds of displays it must be shorted to GND. "

Also sowohl für das Display welches Du mit mitgegeben hast und auch das was wir noch aus China bekommen eine Lötbrücke auf die beiden unteren Punkte (die mehr zum Rand sind )? Da solltest Du IMHO die Doku erweitern. Was hältst Du im nächsten Release  von nem Jumperblock auf der Oberseite inkl. Beschriftung? Dann kann man auch schnell umstecken.

Direkt noch die nächste Anregung: Die Befestigungslöcher, kann man die so setzen dass es für die meisten Williams passt? Beim Comet würden drei hinhauen wenn man APC links unten plaziert. Die beiden unteren stimmen fast (Bohrung zu klein) und für die dritte sind die Switchstecker im Weg, die müsste man dann etwas verschieben ...

Share this post


Link to post
Share on other sites
Quote

Edit: wohl nicht, nur rauschen im Test, ich bestück mal weiter

Ich hoffe zu wissen, was los ist. Wie ich sehe hast du schon RR8 bestückt. Da der Rest der Switch-Schaltung noch fehlt erkennt er alle Schalter als aktiv und dann läuft ihm der Buffer für die geänderten Schalter über. Normalerweise sollte er alles über 30 gleichzeitigen Änderungen verwerfen, aber da steckt ein Fehler in der Abfrage.

Geh doch mal bitte zur Hauptschleife 'void loop()', da sollte es folgendermaßen aussehen:

void loop() {
	byte c = 0;                                  				// initialize counter
	if (SwEvents[SwitchStack]) {                        // switch event pending?
		SwitchStack = 1-SwitchStack;                      // switch to the other stack to avoid a conflict with the interrupt
		while (SwEvents[1-SwitchStack]) {									// as long as there are switch events to process
			if (ChangedSw[1-SwitchStack][c]) {							// pending switch event found?
				SwEvents[1-SwitchStack]--;										// decrease number of pending events
				i = ChangedSw[1-SwitchStack][c];							// buffer the switch number
				ChangedSw[1-SwitchStack][c] = 0;							// clear the event
				if (QuerySwitch(i)) {                         // process SET switches
					Switch_Pressed(i);}													// access the set switch handler
				else {																				// process released switches
					Switch_Released(i);}}												// access the released switch handler
			if (c < 29) {                                   // number of pending events still in the allowed range?
				c++;}																				  // increase counter
			else {
				ErrorHandler(21,0,c);}}}

Die 29 in der vierten Zeile von unten produziert den Error 21. Da muss stattdessen eine 30 stehen, da der Buffer auch 30 Byte groß ist. Danach ist der Error 21 hoffentlich weg und du solltest was hören.

 

4 hours ago, bontango said:

Lötbrücke auf die beiden unteren Punkte (die mehr zum Rand sind )?

Genau.

4 hours ago, bontango said:

Die Befestigungslöcher, kann man die so setzen dass es für die meisten Williams passt?

Ich habe da mal etwas herumprobiert, aber es gibt so viele verschiedene Modelle, da liegt man immer irgendwie daneben. Von daher habe ich die Platine einfach so klein wie möglich gemacht, dann braucht man halt einen einfachen Befestigungsrahmen.

Share this post


Link to post
Share on other sites

das mit dem auf 30 setzen hat die Sacher eher verschlimmbessert, ABER ich habe dann kurzerhand Step3 (Switches) vorgezogen, und siehe da:

SD card found
Playing music
Playing Sound
Playing Sound
Playing Sound


UND es funktioniert einwandfrei am Comet! Super Sound! Sauberes Design, Respekt. 👍

 

PS:

Ein Sache noch für die Fehlerliste: C20 (100nF) ist in der BOM ne DIP Variante, auf dem Board aber SMD

 

Share this post


Link to post
Share on other sites
Quote

das mit dem auf 30 setzen hat die Sacher eher verschlimmbessert

OK, dann muss ich da wohl nochmal ran. Das sich alle Switches gleichzeitig verändern ist zwar nicht übermäßig realistisch aber die Software sollte damit trotzdem umgehen können.

1 hour ago, bontango said:

UND es funktioniert einwandfrei am Comet! Super Sound! Sauberes Design, Respekt.

Dito, in Rekordzeit aufgebaut würde ich sagen.

Quote

Ein Sache noch für die Fehlerliste: C20 (100nF) ist in der BOM ne DIP Variante, auf dem Board aber SMD

Kommt auf die Liste.

Wenn du in dem Tempo weiter machst, bist du morgen fertig.:banano: 

Share this post


Link to post
Share on other sites

Noch was: wenn du das Board erst mal nur in deinem Comet verwenden möchtest, dann kannst du die Sys7 Stecker weg lassen. Bei allen Steckern, die doppelt ausgeführt sind, ist der innere für Sys9 und Sys11 und der äußere für Sys3 bis Sys7, d.h. du brauchst die äußeren nicht unbedingt zu bestücken.

Share this post


Link to post
Share on other sites

Danke für den Tip, spart mir einiges an Marterial und Aufwand 🙂

Noch ne kurze Frage: Der TDA vom Audioverstärker braucht keinen Kühlkörper?

Share this post


Link to post
Share on other sites
1 hour ago, bontango said:

Der TDA vom Audioverstärker braucht keinen Kühlkörper?

Also ich habe zwar einen hier liegen, aber nie verwendet. Wenn du nicht gerade die ganze Straße beschallen willst dann sollte es auch ohne gehen. Außerdem haben diese ICs normalerweise einen Temperatursensor drin, d.h. er geht einfach aus wenn‘s ihm zu warm wird.

Share this post


Link to post
Share on other sites

Dazu müsste die Bauteilliste entsprechend aufgearbeitet sein und dazu fehlt mir gerade die Energie.

Ich tu mich schon schwer genug damit die Doku zu aktualisieren.

Leuchten die Displays schon?

Share this post


Link to post
Share on other sites
vor 17 Stunden schrieb Black Knight:

ch tu mich schon schwer genug damit die Doku zu aktualisieren.

Ja, können wir ja sehen wenn mal alles läuft, evtl. sind ja noch Änderungen nötig.

btw: c22 & c26 sind auch SMD auf der Platine und Dip in der BOM

vor 17 Stunden schrieb Black Knight:

Leuchten die Displays schon?

Hab jetzt erst einmal die Platine komplett gelötet, gestern spät fertig geworden, Test steht aus.

Das System11 Display scheint aber doch nicht 100% Anschlusskompatibel mit der 9er Verkabelung zu sein.

Beide haben vier Stecker, aber passen würden nur zwei davon, muss mich jetzt mal in die Schematics vertiefen.

Aber soweit ich sehen konnte, würden die Stecker von deinem Display-Treiber (zumindest von der Polanzahl) passen.

Share this post


Link to post
Share on other sites

Hallo Ralf,

bin gerade beim Det, daher die Antwort unter dem anderen Namen.

Der komplette Schaltplan ist am Anfang der WIKI Homeseite verlinkt (Abschnitt How to start)

Frank

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb det:

Der komplette Schaltplan ist am Anfang der WIKI Homeseite verlinkt (Abschnitt How to start)

Ah, da hats mehrere Seiten, hatte nur die erste gesehen. Danke

Share this post


Link to post
Share on other sites
5 hours ago, bontango said:

Beide haben vier Stecker, aber passen würden nur zwei davon, muss mich jetzt mal in die Schematics vertiefen.

Du hast Recht, die APC Seite passt, aber am Display nicht. Vor allem ist der Powerstecker anders, du solltest also auf deinem Powerboard die Hochvolt Sicherungen entfernen, bevor die Displaysteuerung gegrillt wird.

Share this post


Link to post
Share on other sites

Wenn ich das richtig sehe, hat sich nur die Position des Ground Pins im Powerstecker verändert. Der andere Stecker sollte passen, er hat halt nur 3 Pins mehr die du nicht brauchst.

Share this post


Link to post
Share on other sites

Ich hab das jetzt so rausgelesen, dass nur der Key unterschiedlich ist und statt 90Volt jetzt 100Volt ankommen

Pin --- SYS9 -- Sys11

1   GND         GND

2   KEY       N.C.

3   -100V   -100V

4   +100V   +90V

5   N.C.    KEY

6   +5v DC    ++5v DC

Ich brauch ja eh nur die 5Volt und GND richtig?

Edited by bontango

Share this post


Link to post
Share on other sites

Ich such mir gard nen Wolf bei den Steckernummern, die sind bei System 9 ganz anders als sys7 bzw. sys11, oder?

Noch ne Frage: was für ein Display muss ich in den Defaults einstellen, default ist ja '0'?  SYS11 hats mehrere ...

Share this post


Link to post
Share on other sites

Die Steckernummern am CPU Board sind identisch mit Sys11, am Display leider nicht.

Es scheint sich auch innerhalb von Sys11 immer wieder die Belegung des Powersteckers geändert zu haben :my_huh:

Das Display, das ich dir mitgegeben habe gehört in eine F-14 und hat den Key auf Pin4, GND auf Pin 5 und 5V auf Pin 6.

Das Display, das du demnächst von mir kriegst basiert auf dem Pinbot und hat den Key auf Pin 5, GND auf Pin 1 und 5V auf Pin 6.

D.h. mit deinem zukünftigen Display musst du nur den Key versetzen aber so lange du mit dem F-14 Display arbeitest muss auch der GND and Pin 5.

Mann ist das ätzend, aber wenn du die HV Sicherungen ziehst kannst du eigentlich nichts kaputt machen.

Share this post


Link to post
Share on other sites

OK, sieht ganz gut aus, aber die Arbeit wäre vermutlich nicht nötig gewesen.

Schau mal im APC Schaltplan. Da steht der Sys11 Steckername immer rechts neben oder unter dem Stecker. Die einzige Ausnahme ist der Lautsprecherstecker da der in den verschiedenen Sys11 Versionen mal auf dem Soundboard und mal auf dem CPU Board sitzt, aber ansonsten solltest du im Schaltplan immer den Sys11 (und damit auch Sys9) Klarnamen finden.

Die beiden Anmerkungen mit der unterschiedlichen Pinzahl sind korrekt. Beim J3 muss der Key beachtet werden, dann stehen 3 Pins des Steckers über, aber da ist genug Platz dafür. Beim J13 bleiben einfach drei Pins frei.

Zu J9 gibt's im APC kein Gegenstück, da dieser Stecker meines Wissens nach nie benutzt worden ist.

Share this post


Link to post
Share on other sites
vor 41 Minuten schrieb Black Knight:

da viele Leute diese Informationen vermutlich nicht im Schaltplan suchen.

Oder noch besser direkt auf der Platine, hast Du ja teilweise schon drauf (ich mach mir jetzt noch Aufkleber)

beim Suchen im Schaltplan habe ich dafür viel gelernt

vor 15 Stunden schrieb Black Knight:

Es scheint sich auch innerhalb von Sys11 immer wieder die Belegung des Powersteckers geändert zu haben :my_huh:

Das Display, das ich dir mitgegeben habe gehört in eine F-14 und hat den Key auf Pin4, GND auf Pin 5 und 5V auf Pin 6

Ja, tatsächlich, guter Hinweis ... ich mach mir jetzt zum testen eine kleinen Adapter ...

Gleich gehts los, erster Test 😁werde berichten

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Privacy Policy and Community Guidelines