Jump to content

disco fever - williams system 3


 Share

Recommended Posts

hallo,

habe eine interessante sache hier stehen - vielmehr zwei: Disco Fever - der eine funktioniert (zustand gut), der andere (super zustand) leider nicht. bin bei williams (noch) nicht so der held...deshlab meine bescheidene frage zu den dipslays:

gestern beim erstmaligen einschalten waren alle 4 + master kurzzeitg da. heute dann nur kurz das vom spieler eins (kurzes aufflackern), ansonsten geht keines der displays (der kleine orangene punkt ist auf den vier spielerdisplays zu sehen) mehr.

displays sind alle top, hatte sie im anderen kurz getestet...

spannungen auf dem powerpoard gemäß Marvin gemessen - sind alle perfekt da! auch die 5v eingang am CPU board. habe 2 batterien eingelötet, 3,25v liegen an.

weiss leider nicht wie weiter...

gruß j´

ps beide PFs laufen einwandfrei, hier liegt kein fehler!

Edited by joelany
Link to comment
Share on other sites

Da wird die MPU einen Fehler haben. Wenn die Displays nichts anzeigen, nur einen Leuchtpunkt, und alle relevanten Spannungen vorhanden sind, dann läuft das Programm nicht. Das kann im einfachsten Fall ein Sockelfehler sein, ansonsten kann es alles mögliche auf der MPU sein.

Grüße

Drugi

Link to comment
Share on other sites

tja, das habe ich mir schon gedacht, nachdemich neben Marvin nun auch Marks guide durch habe...

schaue mir in jedem falle mal den 5101 und 6810er an und tausche die mal, wenn das geht...

ansonsten ab zum "doktor" Drugi...

grüße

Link to comment
Share on other sites

sodele,

IC6 ist defekt (7806) => wenn ich den im fkt. Fever einsetze, zeigen die displays nur sporadische "nuller" auf einigen digits an

IC 20 (ROM) scheint auch defekt zu sein

ABER: setze ich die ICs (IC6 + IC 20) von der fkt. CPU in den "defekten" fever, dann springt das gerät beim einschalten meistens in den testmodus. ist der flipper dann endlich im spielemodus und ich möchte spiele am münzprüfer abdrücken - oder drücke den credit knopf, dann gehen alle displays aus...sonst keine funktionen, kein sound.

rätselnde grüße j´

ps ist der IC 7818 für IC 20 der richtige? im fktnierenden ist hier ein 7748er drin?

Link to comment
Share on other sites

IC 6 ist ein Decoder= 74154 wenn der kaputt ist hast du zwar keine Anzeige, das Spiel würde aber funktionieren. Der IC liegt am Ende der Kette, da sollte man den Fehler zum Schluss suchen.

IC 20 ist ein Rom 1 welches die Williamsnummer aufgedruckt hat in diesem Fall 5A-9007.

IC 17 ist Rom 2 und soll die Nummer 5A-9008 haben.

Du schreibst wohl immer die Produktionsdaten ab z.B. 7806, 7818

Grüße

Drugi

Link to comment
Share on other sites

Halo Helmut,

wieder was gelernt mit dem aufgedruckten top.gif

habe endlich eine schematische Darstellung der CPU SYS 3 gefunden und kann damit auf die kontrolle der ROMs/RAMs gehen.

aber wo bekomme ich die INFO her, welche IC typen auf der Platine bestückt sind?

ist schon blöd gemacht, keine beschriftung auf der platine, im Handbuch stehen dann nur die IC Plätze...genauso mit den steckerbezeichnungen...

gruß joachim

Edited by joelany
Link to comment
Share on other sites

Die normalen TTL ICs haben ja keine Williamsnummer, lediglich manchmal die CPU und RAMs. Die Spiele Proms haben natürlich immer eine eigene Bezeichnung, und die Flipper Roms haben sich ab und zu geändert, je nachdem wie das Einstellmenue geändert wurde.

Link to comment
Share on other sites

so, bin für meine verhältnisse einen schritt weiter...komme in den test modus rein, untere LED bleibt an, was ja heisst, dass ein Fehler bei den ROM/PROMs liegt (IC 17/20/21 oder 22).

das blanking signal auf dem interconnector an PIN 4 (und 37) ist leider ungleich den geforderten 5V, hier liegt nix an...könnte einen weiterführenden tipp gebrauchen;)

gruß j´

Link to comment
Share on other sites

Wenn die untere LED leuchtet ist es nach dem Testablauf IC 13 Ram. Das ist aber zu 99% nicht der Fall, weil der Test wohl nicht erfolgreich war. Wie du schon vermutest wird ein Prom der ROM defekt sein. Denn erst wenn diese in Ordnung sind ist der Selbsttest zuverlässig.

Da bin ich aber froh, daß das Blankingsignal noch low ist. Wenn es high wäre könnten unkontrolliert einige Spulen gleichzeitig anziehen oder die geschalteten Lampen werden voll durchgesteuert und bekommen 18 Volt, was schön hell ist aber nicht von langer dauer. biggrin.gif . Lange Rede kurzer Sinn: Blanking ist erst high, wenn das Programm alle relevanten Komponenten als in Ordnung getestet hat.

drugi

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Privacy Policy and Community Guidelines