Jump to content

Bally/Stern Replacement MPU 'LISY35', Tester gesucht


bontango

Recommended Posts

Servus in die Runde - mein Update:

Projekt macht viel Spass, grosses Danke an bontango :top:

Löten war top, habe allerdings aus welchem Grund auch immer den Switch PIC falsch gesteckt. Hoffe dieser hat es überlebt...(wie kann ich das überprüfen?weil:)Es scheint alles zu funzen inkl. Wlan. Alles auf aktuellem Stand. Nur die Dolly sträubt sich: Braucht eine Sicherung 10A, 32V, 3AG

Mal schauen wie schnell sich diese auftreiben lässt.

Grüsse

Steve

Link to comment
Share on other sites

  • Replies 187
  • Created
  • Last Reply

Top Posters In This Topic

  • bontango

    65

  • Thunfisch

    39

  • Volley

    29

  • hausmeister

    15

Top Posters In This Topic

Posted Images

Ich fände es gut wenn die letzte update URL gespeichert würde.

Im menue "set hostname" fehlt mir die Anzeige des aktuellen hostnamen.

Kann man die Länge des Hostnamen etwas verlängern? 8 Zeichen ist ein bisschen kurz, dariegt man viele Flippernamen nicht unter...

Link to comment
Share on other sites

vor 11 Stunden schrieb moosmann:

(wie kann ich das überprüfen?

So in LISYcontrol sauber die Softwarestände abgefragt werden können funzen die PICs schon mal grundsätzlich.

So einzelne I/O Pins Schaden genommen haben merkt man das nur im Betrieb, bei einfachem vertauschen

ist allerdings unwahrscheinlich dass da was Schadenn genommen hat.

Beliebt ist dagegen Spulenspannung auf die Switchmatrix zu geben, das mag der Switch PIC gar nicht 😱

Link to comment
Share on other sites

vor 9 Stunden schrieb Volley:

Ich fände es gut wenn die letzte update URL gespeichert würde.

Im menue "set hostname" fehlt mir die Anzeige des aktuellen hostnamen.

Kann man die Länge des Hostnamen etwas verlängern? 8 Zeichen ist ein bisschen kurz, dariegt man viele Flippernamen nicht unter...

Kann ich machen ...

Link to comment
Share on other sites

Hallo zusammen,

nachdem heute die letzten Teile von Reichelt gekommen sind (beim ersten Versuch wurde etwas falsches eingepackt), stehe ich jetzt von dem Flash-Prozess. Das Update für das Solenoid-PIC auf die Version 4.03 ist empfohlen, und auch schon im 5.005-Image enthalten gewesen. Trotzdem will es bei mir nicht funktionieren.

Also habe ich die Variante über die Update-Oberfläche probiert. Lustigerweise bekomme ich zu dieser nur Zugang, wenn das Board auch im Flipper hängt. Bin ich mit einem USB-Kabel am RasPi, bekomme ich keine Web-Oberfläche zustande. Der Flash-Vorgang wird am PC mit OK quittiert, am Board leuchtet aber nur die gelbe LED (siehe Bild).

Nachdem ich den Frontier wieder eingeschaltet habe, habe ich jetzt noch keinen Ton. Bumper und Ziele funktionieren, ebenso die Display-Anzeigen der Spielstände. Es wird nur der Münzeinwurf nicht richtig gezählt. Bei den Lämpchen habe ich noch nicht alles kontrolliert, aber es sieht erst einmal gut aus.

VG

Bodo

IMG_2781.JPG

IMG_2780.JPG

Link to comment
Share on other sites

vor 53 Minuten schrieb hausmeister:

Also habe ich die Variante über die Update-Oberfläche probiert. Lustigerweise bekomme ich zu dieser nur Zugang, wenn das Board auch im Flipper hängt. Bin ich mit einem USB-Kabel am RasPi, bekomme ich keine Web-Oberfläche zustande.

Bist Du in dem Moment näher an deinem WLAN Router? Der PI hat keine so guten Empfangseigenschaften

 

vor 53 Minuten schrieb hausmeister:

Der Flash-Vorgang wird am PC mit OK quittiert, am Board leuchtet aber nur die gelbe LED (siehe Bild).

Das OK gilt! Die grüne LED muss ich noch programmieren, geht derzeit nur im Flash 'Sparmodus'

 

vor 24 Minuten schrieb hausmeister:

Ja, an S1 sind DIP 1,6,8 oben.

Für das einfache 'Flash PIC' sollten es aber S1, dip 2,6,8 auf ON sein

Link to comment
Share on other sites

vor 4 Stunden schrieb bontango:

Bist Du in dem Moment näher an deinem WLAN Router? Der PI hat keine so guten Empfangseigenschaften

Nein. Deshalb hatte ich es erwähnt. Ich bin sogar näher am Router gewesen. Vielleicht ist es aber dennoch ein Empfangsproblem gewesen. Kann man den kleinen RasPi mit einer besseren Antenne bestücken? Letztlich zählt für mich, das es ja funktioniert hat.

 

vor 4 Stunden schrieb bontango:

Das OK gilt! Die grüne LED muss ich noch programmieren, geht derzeit nur im Flash 'Sparmodus'

Dann ist ja gut! Die grüne LED hat bei mir bislang noch nie geleuchtet. Daher muss ich auch die Lötstellen noch einmal kontrollieren. Wenn das OK auf dem Rechner zählt, ist das für mich i.O.

vor 4 Stunden schrieb bontango:

Für das einfache 'Flash PIC' sollten es aber S1, dip 2,6,8 auf ON sein

Sorry, da hatte ich mich vertippt. Es waren, wie in der Anleitung beschrieben, S1 DIP 2,6,8 auf ON.

Link to comment
Share on other sites

Folgende Anzeigen erscheinen in den 2 Phasen des Bootvorgangs.

Leider springt die grüne LED "LISY 35" nicht an.

Auch die "Bally green LED" leuchtet nicht, nachdem sie 6 mal aufgeleuchtet hat.

IMG_0008.jpg

IMG_0009.jpg

Link to comment
Share on other sites

Beim Frontier habe ich jetzt auch verschiedene Lampen kontrolliert:

Es leuchten auf dem Spielfeld mindestens folgende Lampen nicht:

- Die oberen A, B, C-Leuchten

- Die Bonus-Leuchten für 10.000, 20.000, 30.000, 40.000, 50.000 60.000 Punkte und Spezial

- Die Leuchten für 2x, 3x, 4x Bonus

- Die Bonus-Lampen (15 Lampen mit Tiersymbolen)

Des Weiteren habe ich weiterhin Schwierigkeiten, eine WiFi-Verbindung aufzubauen. Ich bin nach dem ganzen ausprobieren ein wenig ratlos, welche Einstellungen ich jetzt nehmen sollte. In der Grundeinstellung (S1 alle auf OFF) bekomme ich auf jeden Fall keine Webseite angezeigt. Eine SSH-Verbindung klappt aber ohne Probleme (mit User : pi‘, Password : ‚lisy80‘)

Link to comment
Share on other sites

vor 12 Stunden schrieb hausmeister:

Des Weiteren habe ich weiterhin Schwierigkeiten, eine WiFi-Verbindung aufzubauen. Ich bin nach dem ganzen ausprobieren ein wenig ratlos, welche Einstellungen ich jetzt nehmen sollte. In der Grundeinstellung (S1 alle auf OFF) bekomme ich auf jeden Fall keine Webseite angezeigt. Eine SSH-Verbindung klappt aber ohne Probleme (mit User : pi‘, Password : ‚lisy80‘)

Das ist OK so, ssh und ping geht 'immer' sobald du einen connect zum WLAN hast.

Eine Webseite wird aber nur mit LISYcontrol oder dem Web Flash Utility hochgefahren

 

Externe Antenne geht, ist aber nicht ohne:

https://www.briandorey.com/post/raspberry-pi-zero-w-external-antenna-mod

Aber evtl. hat sich das Problem mit meinem Hinweis oben erledigt?!"

Edited by bontango
Link to comment
Share on other sites

vor 12 Stunden schrieb hausmeister:

Beim Frontier habe ich jetzt auch verschiedene Lampen kontrolliert:

Es leuchten auf dem Spielfeld mindestens folgende Lampen nicht:

 

vor 24 Minuten schrieb Volley:

Bei so vielen Lampen tippe ich mal auf ein Kontaktproblem am Stecker J1

Denke ich auch, die Pins von LISY sind ja etwas kleiner, das würde erklären dass es mit der originalen Platine geht.

Insbesonder pins 11-19 von J1 mal anschauen.

oder die 3,2K Widerstände R8 - R18 gegen die ursprünglich vorgesehen 1,2 K Widerstände austauschen, evtl liegt es auch daran!

 

btw: Bei Reichelt habe zu den Pins der Stecker nichts vergleichbares gefunden, hat da jemand evtl. einen Tip/Bezugsquelle?

Edited by bontango
Link to comment
Share on other sites

vor 13 Stunden schrieb hausmeister:

Folgende Anzeigen erscheinen in den 2 Phasen des Bootvorgangs.

Leider springt die grüne LED "LISY 35" nicht an.

Auch die "Bally green LED" leuchtet nicht, nachdem sie 6 mal aufgeleuchtet hat.

Besteht das Problem noch? Bei mir auf dem Schreibtisch bootet er mit der Frontier Einstellung sauber hoch

Link to comment
Share on other sites

vor 34 Minuten schrieb bontango:

btw: Bei Reichelt habe zu den Pins der Stecker nichts vergleichbares gefunden, hat da jemand evtl. einen Tip/Bezugsquelle?

Ich nehme diese hier: <<Klick>>

Die sind mit 8,3mm Stiftlänge etwa 2 mm länger als die von Reichelt. (siehe Datenblatt)

Link to comment
Share on other sites

vor einer Stunde schrieb bontango:

Besteht das Problem noch? Bei mir auf dem Schreibtisch bootet er mit der Frontier Einstellung sauber hoch

Ja und nein.

Die LED „Lisy35“ leuchtet jetzt, was ich für ein gutes Zeichen halte. Da hatte ich ein Kontaktproblem an der Katode.

Die LED „Bally Green LED“ blinkt 6 mal. Dann bleibt sie aus.

Link to comment
Share on other sites

vor 1 Stunde schrieb bontango:

oder die 3,2K Widerstände R8 - R18 gegen die ursprünglich vorgesehen 1,2 K Widerstände austauschen, evtl liegt es auch daran!

Bei mir sind die Widerstände R8-R18 immer die 1,2k Widerstände gewesen. Braun, rot, rot bedeutet für mich 12x100=1200 Ohm.

Sollte ich daran etwas ändern?

Link to comment
Share on other sites

vor 3 Stunden schrieb bontango:

btw: Bei Reichelt habe zu den Pins der Stecker nichts vergleichbares gefunden, hat da jemand evtl. einen Tip/Bezugsquelle?

Dass die Secker bei der Lisy so verdächtig leicht drauf und runter gehen, ist mir auch schon aufgefallen, und ich hatte auch schon interessante Effekte, die mit An-allem-Seckern-mal-wackeln weggingen, weswegen ich es hier nicht erwähnt hatte. Die Pins in meiner Bastelkiste haben dagegen ein mehr originales Auf- und Absteckfeeling, aber wo habe ich die her? Vermutlich aus Gelsenkirchen 🙂

 

Am 21.12.2018 um 09:07 schrieb bontango:

[...] als nächstes kompletiere ich LISY_control ( damit alle Ihre config files uploaden können 😉)

Kannst Du dann mal die Formatvorlagen hier posten (bzw. den Link darauf, vermutlich liegen sie längst hier irgendwo...) Danke!

Am 20.12.2018 um 20:20 schrieb bontango:

Ich habe auch Hoffnung dass die kleineren Probleme beim Main Lampdriverboad sowie die 2518-53er Board (Pac Man) behoben sind
Wer sich nicht jedesmal 1,5 GB ziehen und die SD Karte beschreiben will UND LISY am Internet hängen hat, kann auch mal die updatefunktion in LISY_Control ausprobieren.

Das Updaten über die Funktion in LisyControl hat prima funktionert, geht viel viel viel schneller, als jedesmal die 1,5 GB zu saugen und zu flashen. AUßerdem überschreibt es nicht die SSID und das Paßwort 🙂 Und wenn bald die Configfiles dazukommen ...

Leider seh ich nach dem Update in meiner XENON keinen Unterschied zu vorher, was die durch das AuxBoard gesteuerten Lämpchen betrifft. Auf dem Aux-Lamp-Driver steht als Nummer irgendwas mit -52.

Macht immernoch Spaß

Den Locheffekt beim NitroGroundShaker teste ich nachher.

Gruß

Martin

P.S.: Wir füge ich Text VOR das erste Zitat ein?

P.P.S.: Auch diesmal hat LISY erst beim zweiten Versuch eine IP-Adresse angezeigt, das ist jetzt langsam so eine Regelmäßigkeit, dass es sich fast zu erwähnen lohnt. Gibt es eine andere Möglickeit als Ausschalten, um auf die ganzen Nullen an Stelle der IP-Adresse zu reagieren?

Edited by Thunfisch
Link to comment
Share on other sites

vor 1 Stunde schrieb hausmeister:

Bei mir sind die Widerstände R8-R18 immer die 1,2k Widerstände gewesen. Braun, rot, rot bedeutet für mich 12x100=1200 Ohm.

Sollte ich daran etwas ändern?

Ne ,alles gut dann, aber sicherheitshalber einmal messen.

Du warst ja Nachzügler, in der Sammelbestellung hatte Reichelt die falschen geliefert ( Orange, Orange, Rot ) kann man leicht verwechseln.

Link to comment
Share on other sites

vor 12 Minuten schrieb Thunfisch:

Kannst Du dann mal die Formatvorlagen hier posten (bzw. den Link darauf, vermutlich liegen sie längst hier irgendwo...) Danke!

Liegen in /lisy/lisy35/control jeweils in den Unterverzeichnissen. Beispieldateien vom Mata Hari auch.

Namenskonventionen: -> Manual Kapitel 10 LISYcontrol

Link to comment
Share on other sites

Hi,

ich hätte noch eine Frage.

Am Ende der Liste der unterstützten Spiele wird es nochmal spannend. Sind da die modifizierten ROMs von "okaegi" dabei? Kann / soll man die auch schon testen?

Gruß

Martin

Link to comment
Share on other sites

Und noch eine Frage:

Zu den Dip-Switches. Lisy_Control kann da als Editor benutzt werden. Ich kann also zu den DIP-Switches die Bedeutung dort eintragen. Er zeigt mir aber alle auf "off" - muss ich die tatsächlichen Schalterstellungen von Hand übertragen? Und, wenn ich das einmal gemacht habe, gelten dann die echten DIP-Schalter nicht mehr, sondern nur noch, was hier steht?

Danke und Gruß

Martin

P.S.: Fröhliche Weihnachten!

Link to comment
Share on other sites

vor 3 Minuten schrieb Thunfisch:

Am Ende der Liste der unterstützten Spiele wird es nochmal spannend. Sind da die modifizierten ROMs von "okaegi" dabei? Kann / soll man die auch schon testen?

Ichhabe die noch nicht ins Image aufgenommen, aber welche möchtest Du denn testen, dann schieb ich dei in die 5.006

 

vor 1 Minute schrieb Thunfisch:

Zu den Dip-Switches. Lisy_Control kann da als Editor benutzt werden. Ich kann also zu den DIP-Switches die Bedeutung dort eintragen. Er zeigt mir aber alle auf "off" - muss ich die tatsächlichen Schalterstellungen von Hand übertragen? Und, wenn ich das einmal gemacht habe, gelten dann die echten DIP-Schalter nicht mehr, sondern nur noch, was hier steht?

Ja, da muss ich noch mal ran, LISYcontrol liest hier nicht die aktuellen Dip-Switches als Vorlage aus, auskommt in 5.006

Wenn Du das dann abspeicherst legt er eine Definitionsdatei für diesen Flipper an, beim nächsten Start nimmt er dann nur noch diese Einstellung

und ignoriert die Switches auf der Platine (bis du diesen File löschst; liegt unter /lisy/lisy35/dips )

Link to comment
Share on other sites

Habe gerade mal den Zugriff per SSH (WinSCP) probiert.

Login mit pi / lisy80 funktioniert und ich kann mich über  /boot/lisy/lisy35 zu den Dateien hangeln.

Login mit root / bontango wie im Handbuch beschrieben funktioniert nicht. Ist dann ja eigentlich auch nicht notwendig ?

Beste Grüße

Holger

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Privacy Policy and Community Guidelines