Jump to content

Bally/Stern Replacement MPU 'LISY35', Tester gesucht


bontango

Recommended Posts

Hi!

Zur Erklärung, warum der "Vergisst die Freispielkennzahlen" für mich so wichtig / testverhindernd ist: Freispiele wären mir ja egal. Und der Highscore baut sich dann ja schon wieder auf. Aber: Ich habe statt Frispiele Freibälle dort eingestellt. Wenn das nach dem Einschalten alles weg ist, dann ist das ergebnisrelevant.

Klar kann ich damit weitertesten, aber einfach so drinlassen und alle Besucher zu Mittestern machen geht dann halt nicht mehr so einfach.

Nur zur Erklärung, warum der "kleine" Bug für mcih so relevant ist.

Das Flipperfingerfreigaberelais? Kein Thema. Das muss das schon aushalten, dass es jetzt fälchlicherweise auf "an" ist. Ich denke, das ist dafür gebaut, den ganzen Tag "an" zu sein. Könnte ja auch jemand die Kugel in der Shooterlane liegenlassen tagelang, muss er abkönnen ...

Gruß

Martin

P.S.: Schönen Urlaub!

Link to comment
Share on other sites

  • Replies 187
  • Created
  • Last Reply

Top Posters In This Topic

  • bontango

    65

  • Thunfisch

    39

  • Volley

    29

  • hausmeister

    15

Top Posters In This Topic

Posted Images

Hi.

  • Sind die neu dazugekommenen Bugs im PIC und nicht im Image?
  • Funktioniert die neue Version auch mit dem alten PIC?

Könntest Du dann vielleicht die Vorversion vom PIC wieder zur Verfügung stellen? (Hab die nicht gespeichert...)

Gruß

Martin

EDIT

Wie ich sehe, hast Du es drüben im anderen Forum geändert - lag wohl doch nicht am Pic? Damit hat sich diese Frage hier erübrigt.

Sorry, Ist ein wenig unübresichtlich mit dem Feedback in 2 Foren, ich kann auch nicht überall gleichzeitig sein ...

EDIT vom EDIT Jetzt stehts auch hier ...

Edited by Thunfisch
Link to comment
Share on other sites

Soweit ich das bisher ermitteln konnte ist das PIC nur für den 'grossen' Lampdriverboard bug verantwortlich.

Die alte Version ist noch da, einfach bei dem Link die'5' gegen eine '3' tauschen.

Neue gemeldete Bugs:

- zweites grosses Lampdriverboard geht nicht mehr (Ursache: sol pic 4.05 )
- Highscores werden nicht mehr gespeichert (Ursache: LISY 5.006 )
- Bei Geräten mit 'Gates' bleiben diese offen ( Ursache: LISY 5.006 )
 
 
Link to comment
Share on other sites

vor 1 Minute schrieb bontango:

- Highscores werden nicht mehr gespeichert (Ursache: LISY 5.006 )

- Bei Geräten mit 'Gates' bleiben diese offen ( Ursache: LISY 5.006 )

Hi.

Ich vermute, der "Flipperfingerfreigaberelais ist im Attract mode an" und der mit den offenen Gates ist hängen zusammen?

Gruß

Martin

Link to comment
Share on other sites

Vorsicht mit den Dauerstromspulen! Hab mir gerade ne Spule gegrillt. Stern hat, wohl in Ermangelung von freien Momentary Solenoid Treibern, auch normale Spulen dort angeschlossen. Aktuell eine Auswurfspule des Ballmagazins. Und die hält keinen Dauerstrom aus! Als ich es gerochen habe war es zu spät!

Für den Lisy Web Spulentest hiesse das für mich folgendes:

Auch im Dauerspulentest abschalten nach 5 Sekunden. Evt Alternativ Dauerstrom nach DOPPELKLICK

Abschalten aller Spulen und Lampen wenn man aus dem Test raus geht! Über Expander schalten auch Lampen Spulen (wie auch bei Gottlieb).

Link to comment
Share on other sites

Ärgerlich, OK muss ich mir anschauen

Die Fehler habe ich übrigens gefunden, hat mir keine Ruhe gelassen ..

Ich lade gerade 5.007 mit coil pic Version 4.06 hoch. Lisy_update.tgz ist schon auf dem neuesten Stand

Link to comment
Share on other sites

vor 29 Minuten schrieb Thunfisch:

Ich vermute, der "Flipperfingerfreigaberelais ist im Attract mode an" und der mit den offenen Gates ist hängen zusammen?

Genau, und auch mit den Highscore, ich schreibe nämlich auf das LISY eeprom sobald die Flipperfinger auf disable gehen, was sie ja nicht taten ...

Link to comment
Share on other sites

So, hier mal etwas deteiliertere Daten des heutigen Tests.

Lisy 5.006

Switch 4.01

Display 4.04

Solenoid 4.05

 

Stern Stars

Maschine startet und geht ins Spiel

Displaytest (6-stellig) und Schaltertest OK, sowohl im Maschinentest als auch über Weboberfläche

Spulentest aus Maschine NICHT moglich, aus Weboberfläche und im Spiel OK, Ausnahme K1 Relais (Dauerstrom)

Im Spiel keine Auffälligkeiten. Sound => Glockenspiel OK

 

 

Stern Iron Maiden (Sol 4.05)

Stern Burnintest (Stern testet im ersten Test alles gleichzeitig) geht nicht. Gerät startet mit Lampentest!

Im Selbsttest keine Freispieleinstellungen möglich. Gerät zeigt nur irgendwas auf der 7. Stelle (1. Mio) aller Spieler an. Man sieht das sich was ändert wenn man den Startbutton drückt, aber man erkennt nix!

Dauerfeuer auf K1-Relais und (wie ich später gemerkt habe) auch auf Q17. Spule gegrillt... (Beide Spulen im Dauerspulkenkreis)

Mangels Spule kein Spieltest möglich!

Soundtest unmöglich, Lisy hat keine J5 Steckerleiste!

 

 

Lisy 5.006

Switch 4.01

Display 4.04

Sol/Lamps 4.03 (mit 4.05 Totalausfall Aux Lampdriver und Dauerfeuer auf Dauerspulen)

 

Bally Spectrum

Spectrum geht ins Spiel!

Lampentest aus Maschine: Alle Lampen Hauptlampdriver OK, beim zweiten Lampdriver gehen drei Lämpchen nicht (weder im Test noch im Spiel):

Q24 (J1-5), Q42 (J3-21) und Q56 (J3-10). Kontaktprobleme kann ich wegen des  ordnungsgemäß arbeiten Hauptlampdrivers ausschliessen! Muss also entweder am Pic liegen oder an der Ansteuerung des Pics

Lampentest durch Weboberfläche (Lisy):

Nur Test des Haupt Lampdrivers möglich! Der zweite Lampdriver wird nicht angezeigt!

Mir persönlich fehlen in der Oberfläche noch zwei Buttons: Alle Lampen an und ALLE Lampen aus!

 

Schaltertest OK, sowohl durch Maschinentest als auch über Weboberflächer werden alle Schalter erkannt!

 

Alle Spulen im Test OK, sowohl Maschinentest als auch Webtest

 

Alle Displays werden richtig angesteuert. Im Displaytest der Maschine wird die 7. Stelle (1. Mio) auf allen Displays nicht angesteuert

Spielablauf:

Im Prinzip OK, aber alle Drop Targets zählen keine Punkte nud werden wenn die Bank ab geräumt wird nicht resettet! Da der Spectrum wenn man eine Ratefeld neu belegt alle Targetbänke bei denen mindestens ein Target getroffen wurde resettet (und die anderen Targetbänke nicht) muss er die Schalter auch erkennen! Trotzdem weder Punktewertung noch reset!

Welches Image hast Du hier verwendet? Das von Visual Pinball oder das von Bally? Eventuell liegt ja hier der Fehler? Kontakte 34-39 und 41-47

Link to comment
Share on other sites

Nitro GroundShaker Test

LISY35 version installed is 5.007
Software Switch PIC has version 4.1
Software Display PIC has version 4.4
Software Coil PIC has version 4.6

Alles wie beim letzten Test, außer Rubrik "neu hinzugekommene Fehler". Diese sind wieder weg.

Ich vergaß zuvor zu erwähnen, Trefferquote beim WLAN-Finden auch signifikant besser, bisher kein Fehler.

Fazit:

  • Ersatz für Original-MPU 100%. Fehleranzahl 0.
  • Zusätzliche Features: Ich hätte da schon noch Wünsche an LisyControl ...

Gruß 

Martin

P.S.:  Lohnt es sich, in der Xenon weiterzutesten? Aux Driver Board, Kompliziertere Soundkarte?

Edited by Thunfisch
Link to comment
Share on other sites

Zitat

Lohnt es sich, in der Xenon weiterzutesten? Aux Driver Board, Kompliziertere Soundkarte?

Ja, lohnt immer!

Link to comment
Share on other sites

Hi!

Da ich in meinen Original-MPUs die modifizierten ROMs von "Okaegi" benutze, hab ich mir nun auch mal den Spaß gemacht und die in der Lisy getestet. Den 7-Digit-Umbau hab ich noch nicht gemacht, kann ich daher auch nicht testen 🙂 Aber die Freispielfunktion "Kredite werden nie weniger als 1" funktioniert. Und alles, was mit den Original-ROMS funktioniert, geht immernoch.

Leider basieren die Dateien, die ich im Netz gefunden habe, auf der (ersten) Version von Nitro GroundShaker, wo man den "Lockruf" nicht abstellen konnte. Da der bein Nitro eine völlig missglückte Sirene ist, ist das nicht wonzimmertauglich. Zum Glück gibts von Bally original eine zweite Version, wo man das ausschalten kann. Die hab ich, und aus der hab ich auch Okaegis Patch gemacht.

Gibts diese Version auch irgendwo als Datei in dem Format, das Lisy braucht? Oder, wie macht man aus Original-ROM-Inhalt die Datei für die Simulation?

Gruß

Martin

Link to comment
Share on other sites

@Thunfisch bitte vor Test den Update nochmal wiederholen so Du ihn überLisycontrol gemacht hast

Siehe auch Post auf Flippermarkt

Lisy braucht Roms im pjnmame Format. Wenn Du das selbst gemacht hast wird es da nichts geben.

Du kannst mir das  Image aber mal zuschicken, ( an bontango@lisy80.com ) dann schau ich ob ich das einbinden kann.

Grüße Ralf

Link to comment
Share on other sites

vor 4 Stunden schrieb bontango:

@Thunfisch bitte vor Test den Update nochmal wiederholen so Du ihn überLisycontrol gemacht hast

Hi,

habe nochmal das Update angetoßen. Lieder überschreibt er jedesmal meine SSID und das Paßwort - na egal. Viel wichtiger: Freispielpunktzahlen und Highscore überleben sogar den Updateprozeß!

Jetzt behauptet er nicht mehr, Nitro sei ein Glockenspielflipper. Im LisyControl kann ich nun die Sounds einzeln auslösen. Warum einige Buttons gelb bleiben (untere Hälfte) und andere nicht (obere Hälfte) erschließt sich mir nicht. Analog zu den anderen Buttonwüsten in LisyControl wäre hier auch ein Config-File, in dem man den Sounds Namen geben darf, angebracht  (Kannst Du das auf die Nice-To-Have-Liste nehmen?)

Einer der Buttons schaltete den Hintergrundsound ein, ich weiss nicht mehr, wie ich den wieder ausgekriegt habe (war jedenfalls nichts selbsterklärendes)

Du hast ja mal selbst geschrieben, Webdesign liegt Dir nicht so. Ich kann es leider auch nicht - meine aktive Zeit als Codierer ist schon zu lange her. Aber vielleicht findet sich ein anderer Freiwilliger, der Dir das Design der GUI von LisyControl abnimmt - vor allem, wenn das Thema ohnehin eins ist, das Dir nicht so viel Spaß macht?

Und, wo wir schon bei Nice-To-Have sind: Wenn Du gefunden hast, wohin Bally die Einstellungen des "Kassentürmenüs" schreibt (Freispielpunktzahlen, Highscore, Statistiken, bei einigen auch Einstellungen wie Sound etc.) - auch das wäre eine Seite in LisyControl analog zu der Dipschalterseite wert, finde ich. Also, Nice-To-Have (Prio 5 auf der Skala von 1 - 5)

Nochmals vielen Dank für den Spaß, den mir das Basteln und Testen macht.

Gruß

Martin

Link to comment
Share on other sites

Neuer Test mit Lisy 5.007:

Lisy 5.007

Switch 4.01

Display 4.04

Sol/Lamps 4.06

 

Bally Spectrum

Spectrum geht ins Spiel!

Lampentest aus Maschine: Alle Lampen Hauptlampdriver und Zweit-Lampdriver OK!

Lampdrivertest aus Flipper OK, in der Weboberfläche nur Test des Haupt Lampdrivers möglich! Der zweite Lampdriver wird nicht angezeigt!

Mir persönlich fehlen in der Oberfläche noch zwei Buttons: Alle Lampen an und ALLE Lampen aus!

Schaltertest OK, sowohl durch Maschinentest als auch über Weboberflächer werden alle Schalter richtig erkannt!

Alle Spulen im Test OK, sowohl Maschinentest als auch Webtest

Alle Displays werden richtig angesteuert. Im Displaytest der Maschine wird die 7. Stelle (1. Mio) auf allen Displays nicht angesteuert

 

Spielablauf:

Im Prinzip OK, aber alle Drop Targets zählen immer noch keine Punkte und werden wenn die Bank ab geräumt wird nicht resettet! Da der Spectrum (auch mit Lisy!) wenn man eine Ratefeld neu belegt alle Targetbänke bei denen mindestens ein Target getroffen wurde resettet (und die anderen Targetbänke nicht) muss er die Schalter auch erkennen! Trotzdem weder Punktewertung noch Reset der abgräumten Targetbank (Reset nur bei neuem Ball oder wenn Ratefeld voll)!

Betrifft Kontakte 34-36, 37-39, 42-44 und 45-47

Link to comment
Share on other sites

Für den spectrum habe ich neuere pinmame roms gefunden (rev4), bei dem anderen stand auch was von 'may not run correctly'

Wenn du ein update via LISYcontrol machst LINK kannst Du danach #172 & #173 ausprobieren

Gruesse

Ralf

 

Edited by bontango
typo #174 nach #173 geändert
Link to comment
Share on other sites

On 12/13/2018 at 7:26 AM, bontango said:

Das Blinken bedeutet dass der PI nicht mit den PICs kommunizieren kann.

In 99% der Fälle liegt es am SMD Chip ( I2C Bus Repeater ).

Check noch mal die Lötpunkte nach Kapitel 2.1 aus dem Assembly Guide.

Was ist denn das restliche 1%? Lötpunkte haben alle Kontakt.

Ich hab den Chip erst falsch rum eingelötet (wissen wo Pin1 ist und wissen wo Pin1 hingehört sind zwei verschiedene Dinge ;-)). Kann es sein, dass ich ihn bei Auslöten beschädigt habe? Gibts eine Debugging Möglichkeit um mehr festzustellen?

 

Grüße

 

rwx

Link to comment
Share on other sites

1 hour ago, rwx------ said:

Gibts eine Debugging Möglichkeit um mehr festzustellen?

Lesen bildet.

Ich hab jetzt S1 7 auf ON gestellt. Sollte debug sein. Allerdings ist /boot noch ro:
/dev/mmcblk0p1 on /boot type vfat (ro,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)

lisy_debug_hw.txt scheint folglich auch nicht geschrieben zu werden:
ls -l /boot/lisy/lisy/debug/lisy_debug_hw.txt
-rwxr-xr-x 1 root root 490 Nov  3  2016 /boot/lisy/lisy/debug/lisy_debug_hw.txt

Grüße

rwx

 

Link to comment
Share on other sites

In die  /boot/lisy/lisy/debug/lisy_debug_hw.txt schreibt er nur wenn der hw_check schief läuft

Bei einem boot mit dip7 schreibt er nach /boot/lisy/lisy35/debug/lisy35_debug.txt, schau da bitte mal

 

Gruesse

Ralf

 

 

Link to comment
Share on other sites

Wenn Du eh mit ssh auf der Konsole bist, kannst du auch den I2C Bus mit "i2cdetect -y 1" testen, sollte so aussehen

     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: 40 41 -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

40 & 41 sind die I2C Adressen von Solenoid & Display PIC

Link to comment
Share on other sites

48 minutes ago, bontango said:

40 & 41 sind die I2C Adressen von Solenoid & Display PIC 

Die sind nicht da, also ein Problem mit dem I2C-Bus. Nur um sicherzugehen Pin 1 ist unten links, Pin 8 oben links, korrekt?

Kann ich irgendwie feststellen, ob ich den Chip beim auslöten oder durch den verdrehten Einbau beschädigt habe?

 

50 minutes ago, bontango said:

In die  /boot/lisy/lisy/debug/lisy_debug_hw.txt schreibt er nur wenn der hw_check schief läuft

Bei einem boot mit dip7 schreibt er nach /boot/lisy/lisy35/debug/lisy35_debug.txt, schau da bitte mal 

Da kann er ja nicht hinschreiben, da boot read-only ist. Hab die Datei extra mal leer gemacht, da passiert nichts.

Kann man die position der DIP-Schalter von der Console abfragen? Das Debug nicht geht irritiert mich, sooo schlecht dürften meine Lötfähigkeiten auch wieder nicht sein.

Nachtrag:

root@lisy(ro):/usr/local/bin# ./gpio mode 23 in
root@lisy(ro):/usr/local/bin# ./gpio mode 23 up
root@lisy(ro):/usr/local/bin# ./gpio read 23
0

Wenn ich run_lisy richtig verstehe ist debug also aktiv, wieso ist boot dann read-only?

Edited by rwx------
Link to comment
Share on other sites

Wenn der I2C Bus Probleme hat, kommt er gar nicht bis zu dem Debug, er schaut nur ob er evtl. das Flash-Utility starten soll,

und falls nicht versucht er das Display Pic zu fragen welche HW ( LISY1/35/80) isntalliert ist.

Wenn das schief geht startet er das das 'blinken' ( Ich nehme an er blinkt noch? )

Der Hardware checkscript macht ein remount mit 'rw', schreibt den log, macht nen sync und mounted danach wieder 'ro', daher siehst Du es wieder read-only.

Ich nehme mal an, das Schreiben in die debug_hw hat auch funktioniert, nur das Datum ist nicht aktualisiert.

Wenn er keine Internetverbindung hat kann er nicht das Datum setzen, der Raspberry hat keine HW Uhr die weiterläuft wenn er aus ist.

 

Bleibt also als Fehlerquelle der SMD Chip, oder ein falsch herum eingelötetetes Widerstandsarray 'R40', das macht den I2C Bus Abschluss.

 

 

Link to comment
Share on other sites

25 minutes ago, rwx------ said:

Nur um sicherzugehen Pin 1 ist unten links, Pin 8 oben links, korrekt?

Kann ich irgendwie feststellen, ob ich den Chip beim auslöten oder durch den verdrehten Einbau beschädigt habe?

R40 ist richtig (Punkt / Pin1 ist links).

Link to comment
Share on other sites

Wenn Du alle Punkte nach Anleitung im Board assembly Guide ( letzte Version 1.5 nehmen!) Kapitel 2.1 gecheckt hast

und dabei auch von oben auf die SMD Punkte und nicht auf die Platine gegangen bist, hast Du wohl X1 gebraten 😞

Kann Dir einen zuschicken wenn Du willst

Link to comment
Share on other sites

27 minutes ago, bontango said:

Wenn Du alle Punkte nach Anleitung im Board assembly Guide ( letzte Version 1.5 nehmen!) Kapitel 2.1 gecheckt hast

und dabei auch von oben auf die SMD Punkte und nicht auf die Platine gegangen bist, hast Du wohl X1 gebraten 😞

Kann Dir einen zuschicken wenn Du willst

Punkte hab ich alle gecheckt, die haben Verbindung. Wäre sehr nett, wenn du mir einen zuschicken könntest. Diesmal lass das von jemand löten, der es besser kann als ich.

Link to comment
Share on other sites

vor 1 Stunde schrieb rwx------:

Wäre sehr nett, wenn du mir einen zuschicken könntest

Ist im Kasten, geht morgen auf die Reise ..

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Privacy Policy and Community Guidelines